aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-gst/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-gst/APKBUILD')
-rw-r--r--community/py3-gst/APKBUILD43
1 files changed, 35 insertions, 8 deletions
diff --git a/community/py3-gst/APKBUILD b/community/py3-gst/APKBUILD
index 5d5666b8364..263ff899a62 100644
--- a/community/py3-gst/APKBUILD
+++ b/community/py3-gst/APKBUILD
@@ -1,28 +1,55 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
-# Maintainer:
+# Maintainer: Krassy Boykinov <kboykinov@teamcentrixx.com>
pkgname=py3-gst
-pkgver=1.18.4
+pkgver=1.22.11
pkgrel=1
pkgdesc="GStreamer Python3 bindings"
-url="https://cgit.freedesktop.org/gstreamer/gst-python/"
+url="https://gitlab.freedesktop.org/gstreamer/gstreamer"
arch="all"
license="LGPL-2.1-or-later"
depends="py3-gobject3 gst-plugins-base"
-makedepends="gst-plugins-base-dev gstreamer-dev meson py3-gobject3-dev
- python3-dev"
-source="https://gstreamer.freedesktop.org/src/gst-python/gst-python-$pkgver.tar.xz
+makedepends="
+ gst-plugins-base-dev
+ gstreamer-dev
+ meson
+ py3-gobject3-dev
+ python3-dev
+ "
+source="
+ https://gstreamer.freedesktop.org/src/gst-python/gst-python-$pkgver.tar.xz
+ suffix.patch
"
builddir="$srcdir/gst-python-$pkgver"
+prepare() {
+ default_prepare
+
+ local pyso="$(readlink /usr/lib/libpython*.*.so)"
+ [ -n "$pyso" ]
+ msg "libpython: $pyso"
+ local suff="${pyso#libpython*.so.}"
+ sed -i "s|@SUFF@|$suff|" meson.build
+}
+
build() {
+ CFLAGS="$CFLAGS -O2" \
+ CXXFLAGS="$CXXFLAGS -O2" \
abuild-meson \
+ -Db_lto=true \
-Dpython=/usr/bin/python3 \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
+}
+
+check() {
+ meson test --print-errorlogs --no-rebuild -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="6b9df9e4faaeb030f0596c9e52262c0f82b8854faf821497a840a762913dccb005321c60565754ef571e34976fcda481a41aefbbd486c2932377a95121433bf5 gst-python-1.18.4.tar.xz"
+sha512sums="
+749a3080ad56edfee66c6f24ab106b07cd2a7d6e5f704147a69e12fc0a1da9d9b8d8337c36ce62af459577df3f0804c60cbeb4a211454277ad0a46fd89edcfa5 gst-python-1.22.11.tar.xz
+62e54d028898ff15d51d3fa863f419a533a05bb510b6c391778d2fff5e245143771b38902deb512ac5a7a7d704d7fc9f4e84d22a4761eb85e535b67d0ab640f4 suffix.patch
+"