aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-gst/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-gst/APKBUILD')
-rw-r--r--community/py3-gst/APKBUILD41
1 files changed, 31 insertions, 10 deletions
diff --git a/community/py3-gst/APKBUILD b/community/py3-gst/APKBUILD
index 9c1b3ab5aa1..263ff899a62 100644
--- a/community/py3-gst/APKBUILD
+++ b/community/py3-gst/APKBUILD
@@ -1,28 +1,48 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
-# Maintainer: psykose <alice@ayaya.dev>
+# Maintainer: Krassy Boykinov <kboykinov@teamcentrixx.com>
pkgname=py3-gst
-pkgver=1.20.3
-pkgrel=0
+pkgver=1.22.11
+pkgrel=1
pkgdesc="GStreamer Python3 bindings"
-url="https://cgit.freedesktop.org/gstreamer/gst-python/"
+url="https://gitlab.freedesktop.org/gstreamer/gstreamer"
arch="all"
license="LGPL-2.1-or-later"
depends="py3-gobject3 gst-plugins-base"
-makedepends="gst-plugins-base-dev gstreamer-dev meson py3-gobject3-dev
- python3-dev"
-source="https://gstreamer.freedesktop.org/src/gst-python/gst-python-$pkgver.tar.xz
+makedepends="
+ gst-plugins-base-dev
+ gstreamer-dev
+ meson
+ py3-gobject3-dev
+ python3-dev
+ "
+source="
+ https://gstreamer.freedesktop.org/src/gst-python/gst-python-$pkgver.tar.xz
+ suffix.patch
"
builddir="$srcdir/gst-python-$pkgver"
+prepare() {
+ default_prepare
+
+ local pyso="$(readlink /usr/lib/libpython*.*.so)"
+ [ -n "$pyso" ]
+ msg "libpython: $pyso"
+ local suff="${pyso#libpython*.so.}"
+ sed -i "s|@SUFF@|$suff|" meson.build
+}
+
build() {
+ CFLAGS="$CFLAGS -O2" \
+ CXXFLAGS="$CXXFLAGS -O2" \
abuild-meson \
+ -Db_lto=true \
-Dpython=/usr/bin/python3 \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test -v --no-rebuild -C output
+ meson test --print-errorlogs --no-rebuild -C output
}
package() {
@@ -30,5 +50,6 @@ package() {
}
sha512sums="
-987b444d78b5fb206457245b46b843db9372f9bd316abc57ecd8d50488ef734707a08ac88a9b9d58e2db113e67ce5b524aad82c0086471494c2177c2e272de6e gst-python-1.20.3.tar.xz
+749a3080ad56edfee66c6f24ab106b07cd2a7d6e5f704147a69e12fc0a1da9d9b8d8337c36ce62af459577df3f0804c60cbeb4a211454277ad0a46fd89edcfa5 gst-python-1.22.11.tar.xz
+62e54d028898ff15d51d3fa863f419a533a05bb510b6c391778d2fff5e245143771b38902deb512ac5a7a7d704d7fc9f4e84d22a4761eb85e535b67d0ab640f4 suffix.patch
"