aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-gvm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-gvm/APKBUILD')
-rw-r--r--community/py3-gvm/APKBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/community/py3-gvm/APKBUILD b/community/py3-gvm/APKBUILD
index 77cbd4fbd4a..17e8a083e17 100644
--- a/community/py3-gvm/APKBUILD
+++ b/community/py3-gvm/APKBUILD
@@ -2,31 +2,39 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-gvm
_pkgname=${pkgname/py3/python}
-pkgver=22.6.1
-pkgrel=0
+# follow the same version of gvm-tools
+pkgver=24.3.0
+pkgrel=1
pkgdesc="Greenbone Vulnerability Management Python Library "
url="https://github.com/greenbone/python-gvm"
arch="noarch"
-license="GPL-3.0"
-makedepends="py3-build py3-installer py3-poetry-core"
-checkdepends="py3-defusedxml py3-pytest py3-lxml py3-paramiko"
+license="GPL-3.0-or-later"
+depends="python3 py3-paramiko py3-lxml py3-defusedxml py3-typing-extensions"
+makedepends="py3-gpep517 py3-installer py3-poetry-core"
+checkdepends="py3-defusedxml py3-pytest py3-lxml py3-paramiko py3-pontos"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/greenbone/$_pkgname/archive/v${pkgver/_/.}.tar.gz"
builddir="$srcdir/$_pkgname-${pkgver/_/.}"
build() {
- # XXX: hack for poetry to not ignore files
- GIT_DIR=. python3 -m build --no-isolation --wheel
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ # hangs
+ .testenv/bin/python3 -m pytest \
+ --deselect=tests/connections/test_ssh_connection.py
}
package() {
python3 -m installer -d "$pkgdir" \
- dist/python_gvm-$pkgver-py3-none-any.whl
+ .dist/*.whl
}
sha512sums="
-d40e5ac3508fd3205eaf41dabaf1f57dbf7fc0deaeaa6a82e326f5c7cf844b5d2a7785e5b1e8b1ccf1b04980c420b4f566a7860a9f4a7fcc9feb54426e9b089b py3-gvm-22.6.1.tar.gz
+d6e9dcaf3e776309b18b11393049e2edd08884241a2d050806d9b82dcc91d12e2a121f532b311a83e8f9bf367694b41efe66a9a8eefbe1bfb7bb7453ce08715c py3-gvm-24.3.0.tar.gz
"