aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-h11/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-h11/APKBUILD')
-rw-r--r--community/py3-h11/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/community/py3-h11/APKBUILD b/community/py3-h11/APKBUILD
index 9061e74b6e5..b7b7022a0d4 100644
--- a/community/py3-h11/APKBUILD
+++ b/community/py3-h11/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
-# Maintainer: Antoine Fontaine <antoine.fontaine@epfl.ch>
+# Maintainer: Krassy Boykinov <kboykinov@teamcentrixx.com>
pkgname=py3-h11
-pkgver=0.12.0
-pkgrel=1
+pkgver=0.14.0
+pkgrel=4
pkgdesc="pure-python, bring-your-own-I/O implementation of HTTP/1.1"
url="https://github.com/python-hyper/h11"
arch="noarch"
@@ -10,6 +10,7 @@ license="MIT"
depends="python3"
makedepends="py3-setuptools"
checkdepends="py3-pytest py3-pytest-cov"
+subpackages="$pkgname-pyc"
source="py3-h11-$pkgver.tar.gz::https://github.com/python-hyper/h11/archive/v$pkgver.tar.gz"
builddir="$srcdir/h11-$pkgver"
@@ -22,8 +23,11 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
- rm -rf "$pkgdir"/usr/lib/python3*/site-packages/h11/tests
+ python3 setup.py install --root="$pkgdir"
+
+ rm -r "$pkgdir"/usr/lib/python3*/site-packages/h11/tests
}
-sha512sums="143eab23ae792b04a5cae96e1c6ec88921aebe4c29505b064a150482798110d406b0f395d1492cc0713692a7b64179e09bdf8bda5a6a86d6a93f9d91c8a64cbe py3-h11-0.12.0.tar.gz"
+sha512sums="
+f49d35876cd5e8ca190a6b5187f8580780f0517cb7de78bf32dd1de8a814c9fd000e6ee4db2d72108c8f1b6628157eed8c11ad7940adffde28e410a01c0a318e py3-h11-0.14.0.tar.gz
+"