aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-h2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-h2/APKBUILD')
-rw-r--r--community/py3-h2/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/community/py3-h2/APKBUILD b/community/py3-h2/APKBUILD
index 685bf95d550..34e782b56f5 100644
--- a/community/py3-h2/APKBUILD
+++ b/community/py3-h2/APKBUILD
@@ -3,8 +3,8 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=py3-h2
_pkgname=h2
-pkgver=4.0.0
-pkgrel=1
+pkgver=4.1.0
+pkgrel=3
pkgdesc="HTTP/2 State-Machine based protocol implementation"
url="https://github.com/python-hyper/h2"
arch="noarch"
@@ -16,10 +16,12 @@ depends="
"
makedepends="py3-setuptools"
checkdepends="py3-pytest py3-hypothesis"
+subpackages="$pkgname-pyc"
source="$_pkgname-$pkgver.tar.gz::https://github.com/python-hyper/h2/archive/refs/tags/v$pkgver.tar.gz
- hypothesis-6.6.patch"
+ skip-broken-tests.patch
+ py311.patch
+ "
builddir="$srcdir/$_pkgname-$pkgver"
-[ "$CARCH" = "mips64" ] && options="!check" # tests too slow on mips64
replaces="py-h2" # Backwards compatibility
provides="py-h2=$pkgver-r$pkgrel" # Backwards compatibility
@@ -33,8 +35,11 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="ae145421549ecd29845b100e3895f1088598142824d82cf0b59293b0f647939e4acd0ff809187cabd67a3a524a0337cc925a3f17624c86767bd87a2d18a59b2b h2-4.0.0.tar.gz
-c92a5577338b6ef355a203a2a74ba3d6b997458a179fa7d12eaf4a0f89fe430a2c90a586791afd0c1563d94352586d59aacfb34926c67e5ec7d2236b2c0fcff2 hypothesis-6.6.patch"
+sha512sums="
+4e9cf88b3ae702a8a42bded775ad337809787fe8172d501c230d55abbf1edd764acf3b227f2e58756d882499661ffcf6bbdd4812a4d938c04fac3f1aa2390b28 h2-4.1.0.tar.gz
+a6de0d6342ac3e3b107d5f6863e8b2434d361ac9efbf9eb3fed1e25660ae9d69b8cf5a97cb6d3e94265e4c4aa6d70d2051f050067d7f1ffb59997bfc670e75fb skip-broken-tests.patch
+a91c116b938ffeecc125ad9c55fa6235729235d3f998b030348536648ba8a703e29070cb53869134bec9b6b806144d60598adcfbffb8b283535ddd0e776df00f py311.patch
+"