aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-hatchling/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-hatchling/APKBUILD')
-rw-r--r--community/py3-hatchling/APKBUILD28
1 files changed, 0 insertions, 28 deletions
diff --git a/community/py3-hatchling/APKBUILD b/community/py3-hatchling/APKBUILD
deleted file mode 100644
index a853f48584a..00000000000
--- a/community/py3-hatchling/APKBUILD
+++ /dev/null
@@ -1,28 +0,0 @@
-# Contributor: Duncan Bellamy <dunk@denkimushi.com>
-# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
-pkgname=py3-hatchling
-_pkgreal=${pkgname#"py3-"}
-pkgver=1.3.1
-pkgrel=0
-pkgdesc="Modern, extensible Python build backend"
-url="https://ofek.dev/projects/hatch/"
-license="MIT"
-arch="noarch"
-depends="python3 py3-editables py3-packaging py3-pathspec py3-pluggy py3-tomli"
-makedepends="py3-build py3-installer py3-poetry-core"
-source="https://github.com/ofek/hatch/archive/refs/tags/hatchling-v$pkgver.tar.gz"
-builddir="$srcdir/hatch-$_pkgreal-v$pkgver"
-options="!check"
-
-build() {
- GIT_DIR=. python3 -m build --no-isolation --wheel backend
-}
-
-package() {
- python3 -m installer -d "$pkgdir" \
- backend/dist/$_pkgreal-$pkgver-py3-none-any.whl
-}
-
-sha512sums="
-21fa8bd4ffe0bec5ae9f8b9716ce3b7ece45c6a62bc74f0cd49f759baaa5b21343bcc9f2a8e505f0b724b7d73a4c1f84c863a29e064e95f4aa1a288098adc8d3 hatchling-v1.3.1.tar.gz
-"