aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-hcloud/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-hcloud/APKBUILD')
-rw-r--r--community/py3-hcloud/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/py3-hcloud/APKBUILD b/community/py3-hcloud/APKBUILD
new file mode 100644
index 00000000000..84b336c5fca
--- /dev/null
+++ b/community/py3-hcloud/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Michał Polański <michal@polanski.me>
+# Maintainer: Michał Polański <michal@polanski.me>
+pkgname=py3-hcloud
+pkgver=1.33.2
+pkgrel=1
+pkgdesc="Official Hetzner Cloud Python library"
+url="https://github.com/hetznercloud/hcloud-python"
+license="MIT"
+arch="noarch"
+depends="py3-dateutil py3-requests"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="https://github.com/hetznercloud/hcloud-python/archive/v$pkgver/py3-hcloud-$pkgver.tar.gz"
+builddir="$srcdir/hcloud-python-$pkgver"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ pytest
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/hcloud-$pkgver-py3-none-any.whl
+}
+
+sha512sums="
+a2b85bd1f6580bbf359634084d5c247fc69339ee01900567e7d51db03cc295e7fef989ab4663f4cb8be7dd9c527a6172780557e24b6425760fd615067e54496c py3-hcloud-1.33.2.tar.gz
+"