aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-hcloud/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-hcloud/APKBUILD')
-rw-r--r--community/py3-hcloud/APKBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/community/py3-hcloud/APKBUILD b/community/py3-hcloud/APKBUILD
index 60ce43582ef..84b336c5fca 100644
--- a/community/py3-hcloud/APKBUILD
+++ b/community/py3-hcloud/APKBUILD
@@ -1,20 +1,23 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=py3-hcloud
-pkgver=1.16.0
-pkgrel=0
+pkgver=1.33.2
+pkgrel=1
pkgdesc="Official Hetzner Cloud Python library"
url="https://github.com/hetznercloud/hcloud-python"
license="MIT"
arch="noarch"
-depends="python3 py3-requests py3-dateutil"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest py3-mock"
-source="https://files.pythonhosted.org/packages/source/h/hcloud/hcloud-$pkgver.tar.gz"
-builddir="$srcdir/hcloud-$pkgver"
+depends="py3-dateutil py3-requests"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="https://github.com/hetznercloud/hcloud-python/archive/v$pkgver/py3-hcloud-$pkgver.tar.gz"
+builddir="$srcdir/hcloud-python-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -22,9 +25,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
+ python3 -m installer -d "$pkgdir" \
+ .dist/hcloud-$pkgver-py3-none-any.whl
}
sha512sums="
-de98582691637c1e6978c9056a4765cd0046462b0f38777564a71024b93b5265da40373cb4dc19161397bb2896391610744d5c92f4e3d1a0be88e88a3512c02f hcloud-1.16.0.tar.gz
+a2b85bd1f6580bbf359634084d5c247fc69339ee01900567e7d51db03cc295e7fef989ab4663f4cb8be7dd9c527a6172780557e24b6425760fd615067e54496c py3-hcloud-1.33.2.tar.gz
"