aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-heapdict/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-heapdict/APKBUILD')
-rw-r--r--community/py3-heapdict/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/py3-heapdict/APKBUILD b/community/py3-heapdict/APKBUILD
index 44b522aed2a..bccde73d5a8 100644
--- a/community/py3-heapdict/APKBUILD
+++ b/community/py3-heapdict/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-heapdict
pkgver=1.0.1
-pkgrel=0
+pkgrel=5
pkgdesc="A heap with decrease-key and increase-key operations"
url="https://stutzbachenterprises.com"
arch="noarch"
@@ -10,6 +10,7 @@ license="BSD-3-Clause"
depends="python3"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/H/HeapDict/HeapDict-$pkgver.tar.gz"
options="!check" # Uses internal private API python module
builddir="$srcdir/HeapDict-$pkgver"
@@ -23,7 +24,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="d82e1eaca4b51da1cfd7a43689796523863d4173b4c23aec4c259025dca7775e5aeb58abef66ae8374e996d00aa07e6728d0f2293304202ea0bd3369fb6010be HeapDict-1.0.1.tar.gz"