aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-hidapi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-hidapi/APKBUILD')
-rw-r--r--community/py3-hidapi/APKBUILD34
1 files changed, 26 insertions, 8 deletions
diff --git a/community/py3-hidapi/APKBUILD b/community/py3-hidapi/APKBUILD
index 092afe4c62c..9bffc89bdf6 100644
--- a/community/py3-hidapi/APKBUILD
+++ b/community/py3-hidapi/APKBUILD
@@ -1,27 +1,45 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer:
pkgname=py3-hidapi
-pkgver=0.9.0
+pkgver=0.14.0
pkgrel=2
pkgdesc="Cython interface for hidapi"
url="https://github.com/trezor/cython-hidapi"
arch="all"
license="GPL-3.0-or-later"
-depends="python3"
-makedepends="py3-setuptools cython libusb-dev python3-dev eudev-dev hidapi-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/trezor/cython-hidapi/archive/$pkgver.tar.gz"
+makedepends="
+ cython
+ eudev-dev
+ hidapi-dev
+ libusb-dev
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ python3-dev
+ "
+source="$pkgname-$pkgver.tar.gz::https://github.com/trezor/cython-hidapi/archive/$pkgver.tar.gz
+ cython3.patch"
builddir="$srcdir/cython-hidapi-$pkgver"
build() {
- python3 setup.py build --with-system-hidapi
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --config-json '{"--build-option": ["--with-system-hidapi"]}' \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test --with-system-hidapi
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m unittest -v
}
package() {
- python3 setup.py install --with-system-hidapi --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="0e019902cd20248c889d07c728619094c1fe4f9b12390047921f5b471f3cdd52f61f4f73767a5aab9dd743bff14cf949a609ede23d29ee2ba23d453916bb43c8 py3-hidapi-0.9.0.tar.gz"
+sha512sums="
+50152578c2bc80e4b74f8a2ac0a3dbb8f5e3a5a44b6df0d81a4bc732e91171750b4e3aebce625ace7eb88e890da760a20d425eced50d065063846e9fe465858f py3-hidapi-0.14.0.tar.gz
+bd9d6f0b76b37c5adc945f2795d3abd744c8d35656548f30882f7ef120077caef947b7427f1d67d5c90a5292ec08578ed0bdcec6c24ea19fbe417074d85c343a cython3.patch
+"