aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-hiredis/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-hiredis/APKBUILD')
-rw-r--r--community/py3-hiredis/APKBUILD35
1 files changed, 20 insertions, 15 deletions
diff --git a/community/py3-hiredis/APKBUILD b/community/py3-hiredis/APKBUILD
index 82e430bf2b6..1c9c6dc8de6 100644
--- a/community/py3-hiredis/APKBUILD
+++ b/community/py3-hiredis/APKBUILD
@@ -1,32 +1,37 @@
# Maintainer: Eivind Uggedal <eu@eju.no>
pkgname=py3-hiredis
-_pkgname=${pkgname#py3-}
-pkgver=1.1.0
+pkgver=2.3.2
pkgrel=1
pkgdesc="Python extension that wraps hiredis"
url="https://github.com/redis/hiredis-py"
arch="all"
license="BSD-3-Clause"
-makedepends="python3-dev py3-setuptools hiredis-dev"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
-"
-
-# keep these til after alpine v3.11
-provides="py-$_pkgname=$pkgver-r$pkgrel" # for backward compatibility
-replaces="py-$_pkgname" # for backward compatibility
-
-builddir="$srcdir"/$_pkgname-$pkgver
+makedepends="hiredis-dev python3-dev py3-gpep517 py3-wheel py3-setuptools"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/redis/hiredis-py/archive/v$pkgver.tar.gz
+ fix-sdsalloc.patch
+ fix-setup.patch
+ "
+builddir="$srcdir"/hiredis-py-$pkgver
build() {
- python3 setup.py build_ext --inplace
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 test.py
+ PYTHONPATH="$(echo "$builddir"/build/lib.linux-*)" pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="ad37868376de91303c15ffe6109dc7fadb4f458efdd44b7ddc0a410937a389b8e062ab7d36b1aec3fe324ecafe6b1e5e6b92f547cbf619251dad22a28e02ee9c hiredis-1.1.0.tar.gz"
+sha512sums="
+1a22ab324f9675973c3dc37c55d6dd9cf43fbc161003003a73b2e1dfbb3fed7dcb1433f4fc51045a88cb2735f7c8495b93a819a0a9f6300e05b0cc85160eaace py3-hiredis-2.3.2.tar.gz
+747bce060cec020feeb203d1beedd49f66c03e81b2b4c88c11c769a7440d0c9642d7224f3ce01e9d22f8c551aff4e3b056c5f89da919fccd73e07189951a2367 fix-sdsalloc.patch
+87b01c3fa06e364b5a7943eecba712e952690b560a111025e1fb1b49b257ab0c7282e90ca3af294cc2ca992b994650f574e27ed03588f25ced2f286a41c9f92b fix-setup.patch
+"