aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-hoedown
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-hoedown')
-rw-r--r--community/py3-hoedown/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/py3-hoedown/APKBUILD b/community/py3-hoedown/APKBUILD
new file mode 100644
index 00000000000..58cf134095a
--- /dev/null
+++ b/community/py3-hoedown/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Contributor: Eivind Uggedal <eu@eju.no>
+# Maintainer:
+pkgname=py3-hoedown
+_pkgname=hoedown
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Python binding for hoedown, a markdown parsing library"
+options="!check" # PyPi has no tests in tarball, github releases have broken versioning
+url="https://github.com/hhatto/python-hoedown"
+arch="all"
+license="MIT"
+makedepends="python3-dev py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="e0a51566ad19c1ee774b93b81092d8ab3c8de335e4789ac08f415fdf6f2aa3441ded88f165089cd7874e5dcf5ac1276dcafbb9481ec70d4d89b5d751a905fe18 hoedown-0.3.0.tar.gz"