aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-holidays/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-holidays/APKBUILD')
-rw-r--r--community/py3-holidays/APKBUILD37
1 files changed, 0 insertions, 37 deletions
diff --git a/community/py3-holidays/APKBUILD b/community/py3-holidays/APKBUILD
deleted file mode 100644
index 0b2d3929745..00000000000
--- a/community/py3-holidays/APKBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=py3-holidays
-pkgver=0.11.2
-pkgrel=0
-pkgdesc="Generate and work with holidays in Python"
-url="https://github.com/dr-prodigy/python-holidays"
-arch="noarch"
-license="MIT"
-depends="
- py3-convertdate
- py3-dateutil
- py3-hijri-converter
- py3-korean-lunar-calendar
- py3-six
- python3
- "
-makedepends="py3-setuptools"
-checkdepends="py3-pytest"
-source="https://pypi.python.org/packages/source/h/holidays/holidays-$pkgver.tar.gz"
-builddir="$srcdir/holidays-$pkgver"
-
-build() {
- python3 setup.py build
-}
-
-check() {
- PYTHONPATH="$PWD/build/lib" pytest
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="
-42fd76209c232755cad99636f05a04c127b528ff8a129782204920067fb260ba2e7ca79058c9f856a3b11bf775f64b54488f95111bd4cf8f9e5b507027ab4437 holidays-0.11.2.tar.gz
-"