aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-hsluv/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-hsluv/APKBUILD')
-rw-r--r--community/py3-hsluv/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py3-hsluv/APKBUILD b/community/py3-hsluv/APKBUILD
new file mode 100644
index 00000000000..4ea6a0cd332
--- /dev/null
+++ b/community/py3-hsluv/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Newbyte <newbyte@disroot.org>
+# Maintainer: Newbyte <newbyte@disroot.org>
+pkgname=py3-hsluv
+pkgver=5.0.4
+pkgrel=1
+pkgdesc="Python implementation of HSLuv (revision 4)"
+url="https://www.hsluv.org/"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/h/hsluv/hsluv-$pkgver.tar.gz"
+builddir="$srcdir/hsluv-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ pytest
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+11de08351e82f0b749113b500031187d0bc80e1ca38fedf3eed1097db9325afaa43821789c44374aeb8da954baf87818ef6dff7c7bdf54050198e0a530217a6d hsluv-5.0.4.tar.gz
+"