aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-httpcore/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-httpcore/APKBUILD')
-rw-r--r--community/py3-httpcore/APKBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/community/py3-httpcore/APKBUILD b/community/py3-httpcore/APKBUILD
index 086d1d38cd9..aa17b56c695 100644
--- a/community/py3-httpcore/APKBUILD
+++ b/community/py3-httpcore/APKBUILD
@@ -1,12 +1,12 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=py3-httpcore
-pkgver=0.14.7
-pkgrel=0
+pkgver=1.0.4
+pkgrel=1
pkgdesc="Minimal HTTP client"
url="https://www.encode.io/httpcore/"
license="BSD-3-Clause"
-arch="noarch !armhf !ppc64le" # limited by py3-anyio
+arch="noarch"
depends="
python3
py3-anyio
@@ -14,23 +14,26 @@ depends="
py3-h11
py3-sniffio
"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-hatchling"
checkdepends="
py3-h2
py3-hpack
py3-hyperframe
py3-pytest
- py3-pytest-asyncio
py3-pytest-httpbin
py3-pytest-trio
py3-socksio
"
-subpackages="$pkgname-doc"
-source="https://github.com/encode/httpcore/archive/$pkgver/py3-httpcore-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="https://github.com/encode/httpcore/archive/$pkgver/py3-httpcore-$pkgver.tar.gz
+ remove-fancy-pypi-readme.patch
+ "
builddir="$srcdir/httpcore-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -38,11 +41,11 @@ check() {
}
package() {
- python3 setup.py install --root="$pkgdir" --skip-build
-
- install -Dm644 LICENSE.md "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.md
+ python3 -m installer -d "$pkgdir" \
+ .dist/httpcore-$pkgver-py3-none-any.whl
}
sha512sums="
-6865e97f9b84846bb4e9304ea358b0a28d66fd2d1e244e8a2a439ee446a294ecbc68ac07d5a718fd1c3eceaa44a391d7a8f7f2ca659f1674eb17a90f39987d48 py3-httpcore-0.14.7.tar.gz
+e618a562dbeb2229e9fdc8e63769415c7308614e120f24d0319e8fe9c96ed6de014fcc03ac376737c5791875bb82b2cc486247bfbf235afe11d48f09a2d2a701 py3-httpcore-1.0.4.tar.gz
+ed30ba9568defdf3c9f5e821c576b1f1b088b3819d9f430049af68cace0e874278c7f75cafc446a7e9c0e39f7a9fbe12de11bce022b06ce2bce67e51952c3f8e remove-fancy-pypi-readme.patch
"