aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-httplib2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-httplib2/APKBUILD')
-rw-r--r--community/py3-httplib2/APKBUILD43
1 files changed, 29 insertions, 14 deletions
diff --git a/community/py3-httplib2/APKBUILD b/community/py3-httplib2/APKBUILD
index 8df49bcb7db..50ba0a58f87 100644
--- a/community/py3-httplib2/APKBUILD
+++ b/community/py3-httplib2/APKBUILD
@@ -1,20 +1,31 @@
# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-httplib2
-_pkgname=httplib2
-pkgver=0.19.1
-pkgrel=0
+pkgver=0.22.0
+pkgrel=2
pkgdesc="Python3 HTTP client library"
url="https://github.com/httplib2/httplib2"
arch="noarch"
license="MIT"
-depends="python3"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest py3-pytest-cov py3-pytest-timeout"
-source="https://files.pythonhosted.org/packages/source/h/httplib2/httplib2-$pkgver.tar.gz
- fix-test-inject-space-after-bpo-43882.patch
+depends="
+ py3-parsing
+ python3
"
-builddir="$srcdir/$_pkgname-$pkgver"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+checkdepends="
+ py3-cryptography
+ py3-pytest
+ py3-pytest-cov
+ py3-pytest-timeout
+ py3-six
+ "
+subpackages="$pkgname-pyc"
+source="httplib2-$pkgver.tar.gz::https://github.com/httplib2/httplib2/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/httplib2-$pkgver"
replaces="py-httplib2" # Backwards compatibility
provides="py-httplib2=$pkgver-r$pkgrel" # Backwards compatibility
@@ -24,18 +35,22 @@ provides="py-httplib2=$pkgver-r$pkgrel" # Backwards compatibility
# - CVE-2021-21240
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$PWD/build/lib" python3 -m pytest tests/
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-0c87b3c9923e81c83df5257ce60f7248d86a64aea0a02d5a3f34be68c692c6abd896f95214899dc6e81b23677efc7684a3cba4c1a47261176dd26c3988054e55 httplib2-0.19.1.tar.gz
-88a9106f1005b2a2234c4fe20c3e271122732d25dce08e9f4f355701854fbfb176ad638a4cfee807bbc4cb063bd6913775a0d6b6c6724cb7948d430f985ae4c7 fix-test-inject-space-after-bpo-43882.patch
+77210f85ccaa2d2cf4a6c89f5146ca5eb9a6f26f00e862f6d0716ec73baffdf94714ae1d5eaced4349920b91276a7835e2f028c6d9156e84c241514b198791e5 httplib2-0.22.0.tar.gz
"