aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-humanfriendly/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-humanfriendly/APKBUILD')
-rw-r--r--community/py3-humanfriendly/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/community/py3-humanfriendly/APKBUILD b/community/py3-humanfriendly/APKBUILD
index 6d2a9f249fb..9a0ca3be934 100644
--- a/community/py3-humanfriendly/APKBUILD
+++ b/community/py3-humanfriendly/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-humanfriendly
-pkgver=9.2
-pkgrel=0
+pkgver=10.0
+pkgrel=5
pkgdesc="Human friendly output for text interfaces using Python"
url="https://humanfriendly.readthedocs.io/en/latest/"
arch="noarch"
@@ -10,7 +10,10 @@ license="MIT"
depends="python3"
makedepends="py3-setuptools"
checkdepends="bash py3-capturer py3-docutils py3-mock py3-pytest"
-source="https://files.pythonhosted.org/packages/source/h/humanfriendly/humanfriendly-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/h/humanfriendly/humanfriendly-$pkgver.tar.gz
+ fix-tests.patch
+ "
builddir="$srcdir/humanfriendly-$pkgver"
build() {
@@ -24,10 +27,11 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
find "$pkgdir" -name "*tests*" -delete
}
sha512sums="
-2abb8d7d4dfb84d625e82f3475bea5045c32f548a45999dca97d39e5bc0cd704a9ab45e0b6b87c0d419b447680a3e71e2d9c8cb14ba19117c7ac9b2f56297f00 humanfriendly-9.2.tar.gz
+496700bcea1dabf003c938558bf807fabb41b71192f69622979dd9e243dda9b4b06c5ac8f65cef217df85ebadf99099dc22b50d63216791a569be11081d267d6 humanfriendly-10.0.tar.gz
+c3bd8d8352ad945b3d101ab0fd997d0056adb88ca2a8042adcb2490db9b5ea58d408e48a2db3e54ae3d1f7cb2511dfde41cca725031466be5d834c13ce313cfe fix-tests.patch
"