aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-humanize/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-humanize/APKBUILD')
-rw-r--r--community/py3-humanize/APKBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/community/py3-humanize/APKBUILD b/community/py3-humanize/APKBUILD
index 35befebf3e7..23b5fc3d930 100644
--- a/community/py3-humanize/APKBUILD
+++ b/community/py3-humanize/APKBUILD
@@ -2,35 +2,39 @@
# Maintainer: Thomas Boerger <thomas@webhippie.de>
pkgname=py3-humanize
_pkgname=humanize
-pkgver=4.0.0
-pkgrel=0
+pkgver=4.9.0
+pkgrel=1
pkgdesc="Python humanize functions"
options="!check" # No tests are actually run
-url="https://pypi.python.org/pypi/humanize"
+url="https://pypi.org/project/humanize"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-setuptools py3-setuptools_scm"
+makedepends="py3-gpep517 py3-hatchling py3-hatch-vcs"
checkdepends="py3-mock py3-freezegun py3-pytest"
-source="$_pkgname-$pkgver.tar.gz::https://github.com/jmoiron/humanize/archive/$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/python-humanize/humanize/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
replaces=py-humanize # Backwards compatibility
provides=py-humanize=$pkgver-r$pkgrel # Backwards compatibility
build() {
- git init
- python3 setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/humanize*.whl
}
sha512sums="
-65479e8b484278e99718dd2ab0c047a44420615434889e6b5adadfee2bc14d00828add9b086ace7e4dfbbba471310779154d7eb4c1585b02a257058d44728b95 humanize-4.0.0.tar.gz
+f52cf97ac1e3546b78c9652293ac519ffa4dd449040df31974d8274e4246cc91faf25c2de5a8d4da50d617f15ed082193a4af0bd9044d187f726b8f1192b277c humanize-4.9.0.tar.gz
"