aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-hyperframe/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-hyperframe/APKBUILD')
-rw-r--r--community/py3-hyperframe/APKBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/community/py3-hyperframe/APKBUILD b/community/py3-hyperframe/APKBUILD
index bf890ea17a7..c5aa7f8188f 100644
--- a/community/py3-hyperframe/APKBUILD
+++ b/community/py3-hyperframe/APKBUILD
@@ -1,28 +1,35 @@
# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
-# Maintainer:
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=py3-hyperframe
-pkgver=6.0.0
-pkgrel=5
+pkgver=6.0.1
+pkgrel=4
pkgdesc="HTTP/2 framing layer for Python"
url="https://python-hyper.org/projects/hyperframe/en/stable/"
arch="noarch"
license="MIT"
-depends="python3"
checkdepends="py3-pytest"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/h/hyperframe/hyperframe-$pkgver.tar.gz"
builddir="$srcdir/hyperframe-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$PWD/build/lib" python3 -m pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ gpep517 install-wheel --destdir .testenv --prefix '' .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="54812dcd5bc92ebe8333e6976c2edba7309cff9921fbcbae0eda7666bf7de7758b3646f4738404bcbd069c4904e57710cb312c42ef9b6ae1d88a057b0bd0ca44 hyperframe-6.0.0.tar.gz"
+sha512sums="
+2a5101b2e91e047fe39b32f81a1a8b2240c371fed28a5e1581e743371418388a7dfb55bc819c46a45804e7f00a5231ca54c92aa1b5b41ffeb714b8cb3ac485ca hyperframe-6.0.1.tar.gz
+"