aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-hyperopt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-hyperopt/APKBUILD')
-rw-r--r--community/py3-hyperopt/APKBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/community/py3-hyperopt/APKBUILD b/community/py3-hyperopt/APKBUILD
deleted file mode 100644
index 6ea0ee363ca..00000000000
--- a/community/py3-hyperopt/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=py3-hyperopt
-pkgver=0.2.5
-pkgrel=2
-pkgdesc="Distributed Asynchronous Hyperparameter Optimization in Python"
-url="https://hyperopt.github.io/hyperopt/"
-arch="noarch !mips !mips64" # py3-numpy missing
-license="BSD-3-Clause"
-depends="
- python3
- py3-future
- py3-numpy
- py3-networkx
- py3-tqdm
- py3-scipy
- py3-cloudpickle
- py3-decorator
- py3-nose
- py3-matplotlib
- "
-makedepends="py3-setuptools"
-source="https://github.com/hyperopt/hyperopt/archive/$pkgver/hyperopt-$pkgver.tar.gz"
-options="!check" # Broken on ipython
-builddir="$srcdir/hyperopt-$pkgver"
-
-build() {
- python3 setup.py build
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="283baf3c8043a5be193e50c06aaef016397f27645d02284fb19c3bedfc67c4d4b09869b92928d8d34b07e721f2f01be8d133e76cf96eba682d698cbede596a93 hyperopt-0.2.5.tar.gz"