aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-hypothesis/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-hypothesis/APKBUILD')
-rw-r--r--community/py3-hypothesis/APKBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/community/py3-hypothesis/APKBUILD b/community/py3-hypothesis/APKBUILD
index 27140cd1af2..124a782bcff 100644
--- a/community/py3-hypothesis/APKBUILD
+++ b/community/py3-hypothesis/APKBUILD
@@ -1,16 +1,18 @@
-# Contributor: Drew DeVault <sir@cmpwn.com>
-# Maintainer: Leo <thinkabit.ukim@gmail.com>
+# Contributor:
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Michał Polański <michal@polanski.me>
pkgname=py3-hypothesis
-pkgver=5.37.4
-pkgrel=0
+pkgver=6.99.4
+pkgrel=1
pkgdesc="Advanced property-based (QuickCheck-like) testing for Python"
options="!check"
url="https://hypothesis.works/"
arch="noarch"
license="MPL-2.0"
depends="py3-attrs py3-sortedcontainers"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
checkdepends="py3-pytest py3-coverage py3-tz py3-numpy py3-dateutil py3-pexpect"
+subpackages="$pkgname-pyc"
source="py-hypothesis-$pkgver.tar.gz::https://github.com/HypothesisWorks/hypothesis-python/archive/hypothesis-python-$pkgver.tar.gz
"
builddir="$srcdir/hypothesis-hypothesis-python-$pkgver/hypothesis-python"
@@ -19,7 +21,9 @@ replaces="py-hypothesis" # Backwards compatibility
provides="py-hypothesis=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -32,7 +36,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
-sha512sums="7eb5299bb9a3206773dda56f560e6ec41f49d052b03782e1c10cd2d5fd62dd8757ccd7ba201612769c8ee5326602af5f1ae1bc0626d88b1f30bae0c610fd42be py-hypothesis-5.37.4.tar.gz"
+sha512sums="
+bb1ac9d2881a3577a07cd396c01be5e96bfe45e2a0254a8dc2c51a86718fd225e04943a6e451a015378fe2f813621b2a7e9fd4b757d180bdae5cb3a6d7b7133b py-hypothesis-6.99.4.tar.gz
+"