aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-icu/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-icu/APKBUILD')
-rw-r--r--community/py3-icu/APKBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/community/py3-icu/APKBUILD b/community/py3-icu/APKBUILD
index c9a73d040d6..383d020771f 100644
--- a/community/py3-icu/APKBUILD
+++ b/community/py3-icu/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-icu
_pyname=PyICU
-pkgver=2.6
+pkgver=2.12
pkgrel=1
pkgdesc="Python3 binding for ICU"
url="https://pypi.org/project/PyICU/"
arch="all"
license="MIT"
-makedepends="py3-setuptools python3-dev icu-dev"
+makedepends="py3-gpep517 py3-setuptools python3-dev icu-dev py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/P/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver
@@ -15,7 +16,9 @@ replaces="py-icu" # Backwards compatibility
provides="py-icu=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -23,7 +26,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="ab4c167cbeb80a23904476e51a3c16aa4721e26840b1d4c2f44b5a610e5467a6880c45f27636efb9e44e8e4302a095d437f4868409103270d79ecd56a3d90c9c PyICU-2.6.tar.gz"
+sha512sums="
+75b799df40c43e0f607e3d90b07e0277dd2f37541b671bd24fdc81044facd2ad89ede991becc256d0761a7627afa3a70dd9e9681cef9eaa8e660f021450eb522 PyICU-2.12.tar.gz
+"