aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ijson/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-ijson/APKBUILD')
-rw-r--r--community/py3-ijson/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py3-ijson/APKBUILD b/community/py3-ijson/APKBUILD
new file mode 100644
index 00000000000..07789d35b59
--- /dev/null
+++ b/community/py3-ijson/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
+pkgname=py3-ijson
+pkgver=3.2.3
+pkgrel=1
+pkgdesc="Iterative JSON parser with standard Python iterator interfaces"
+url="https://github.com/ICRAR/ijson"
+arch="all"
+license="BSD-3-Clause"
+depends="python3"
+makedepends="py3-setuptools yajl-dev python3-dev"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ICRAR/ijson/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/ijson-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ pytest
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+cfdbf8efce072f00c4b3c61dd8b3f3164fd5ab757ac18783de992fe25e5ecbcdee92fe728f1345a37996625ab2ddfef6859dfdbdca7a7ece8f3d99750a9d60b0 py3-ijson-3.2.3.tar.gz
+"