aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-img2pdf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-img2pdf/APKBUILD')
-rw-r--r--community/py3-img2pdf/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/community/py3-img2pdf/APKBUILD b/community/py3-img2pdf/APKBUILD
index 777b23b7dad..5e264b2cc90 100644
--- a/community/py3-img2pdf/APKBUILD
+++ b/community/py3-img2pdf/APKBUILD
@@ -1,15 +1,17 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=py3-img2pdf
-pkgver=0.4.1
-pkgrel=0
+pkgver=0.5.1
+pkgrel=1
pkgdesc="Convert images to PDF via direct JPEG inclusion"
url="https://gitlab.mister-muffin.de/josch/img2pdf"
arch="noarch"
license="LGPL-3.0-or-later"
depends="python3 py3-pillow py3-pikepdf"
-makedepends="py3-setuptools"
-checkdepends="py3-pdfrw"
+makedepends="py3-setuptools qpdf-dev libxml2-dev libxslt-dev py3-wheel"
+checkdepends="py3-lxml python3-dev"
+# no tests in pypi tarball
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/i/img2pdf/img2pdf-$pkgver.tar.gz"
builddir="$srcdir/img2pdf-$pkgver"
@@ -31,9 +33,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="
-e71833250509d52b8782a8bc9e12a8de6ab7ae06d5e6e235c0b3787bfad1070b5ed90934b21e4decc9b2c7008eeb0424f9df27e44ec66259916d3a2fdb73d1f1 img2pdf-0.4.1.tar.gz
+e17a920929f6ab08f501b205c38f9cf2fd5a6bd8d41ac4819a5d7463a3cfbeb5376cd5bbee36ab303248610f1d5c8a71a38ff85b14be564e2f39c6eb537ffcaf img2pdf-0.5.1.tar.gz
"