aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-img2pdf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-img2pdf/APKBUILD')
-rw-r--r--community/py3-img2pdf/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/community/py3-img2pdf/APKBUILD b/community/py3-img2pdf/APKBUILD
index a7e36e054f3..5e264b2cc90 100644
--- a/community/py3-img2pdf/APKBUILD
+++ b/community/py3-img2pdf/APKBUILD
@@ -1,15 +1,17 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=py3-img2pdf
-pkgver=0.4.0
-pkgrel=2
+pkgver=0.5.1
+pkgrel=1
pkgdesc="Convert images to PDF via direct JPEG inclusion"
url="https://gitlab.mister-muffin.de/josch/img2pdf"
arch="noarch"
license="LGPL-3.0-or-later"
depends="python3 py3-pillow py3-pikepdf"
-makedepends="py3-setuptools"
-checkdepends="py3-pdfrw"
+makedepends="py3-setuptools qpdf-dev libxml2-dev libxslt-dev py3-wheel"
+checkdepends="py3-lxml python3-dev"
+# no tests in pypi tarball
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/i/img2pdf/img2pdf-$pkgver.tar.gz"
builddir="$srcdir/img2pdf-$pkgver"
@@ -31,7 +33,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="bab9ee6ef5273a686cb10e52bdeb62b6df3c0da99d0f0558677e07dc7ad776c2d62829a2f5e9c5639acfb9fc6e9c5e3a81aed42dc288c2a39d245775f1d4391b img2pdf-0.4.0.tar.gz"
+sha512sums="
+e17a920929f6ab08f501b205c38f9cf2fd5a6bd8d41ac4819a5d7463a3cfbeb5376cd5bbee36ab303248610f1d5c8a71a38ff85b14be564e2f39c6eb537ffcaf img2pdf-0.5.1.tar.gz
+"