aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-incremental/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-incremental/APKBUILD')
-rw-r--r--community/py3-incremental/APKBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/community/py3-incremental/APKBUILD b/community/py3-incremental/APKBUILD
index 1794391d8d1..acfc4f4406e 100644
--- a/community/py3-incremental/APKBUILD
+++ b/community/py3-incremental/APKBUILD
@@ -2,24 +2,31 @@
# Maintainer: prspkt <prspkt@protonmail.com>
pkgname=py3-incremental
_pkgname=incremental
-pkgver=17.5.0
-pkgrel=4
+pkgver=22.10.0
+pkgrel=3
pkgdesc="Library that versions your Python3 projects"
url="https://github.com/twisted/incremental"
arch="noarch"
license="MIT"
-makedepends="python3-dev py3-setuptools"
+depends="python3"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-incremental" # Backwards compatibility
provides="py-incremental=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/incremental*.whl
}
-sha512sums="91443205f7c92ec8f6502f38379c5ac2fe441435ff9490af01e5420d6bb05bb1c666dd612fc45204199a34afd533fd3de1390ca482bb554dfec7d3a22958a4bc incremental-17.5.0.tar.gz"
+sha512sums="
+23a7572db731d1dd9871d309a02f8a29a92b7f1d897e64a2fe053575e7b486ec87e54d5ae9658eb1a82f90ba36b1b1694b58a991d841553f6cb98983725a49c3 incremental-22.10.0.tar.gz
+"