aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-inflect/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-inflect/APKBUILD')
-rw-r--r--community/py3-inflect/APKBUILD38
1 files changed, 21 insertions, 17 deletions
diff --git a/community/py3-inflect/APKBUILD b/community/py3-inflect/APKBUILD
index 395ec862987..5e691170c4d 100644
--- a/community/py3-inflect/APKBUILD
+++ b/community/py3-inflect/APKBUILD
@@ -1,37 +1,41 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=py3-inflect
-pkgver=5.3.0
-pkgrel=1
+pkgver=7.2.0
+pkgrel=0
pkgdesc="Correctly generate plurals, singular nouns, ordinals, indefinite articles; convert numbers to words"
-url="https://github.com/jazzband/inflect"
-arch="noarch !mips !mips64" # py3-pytest-black->black
+url="https://github.com/jaraco/inflect"
+arch="noarch"
license="MIT"
-depends="python3"
+depends="py3-more-itertools py3-typeguard"
makedepends="
+ py3-gpep517
py3-setuptools
py3-setuptools_scm
- py3-toml
- "
-checkdepends="
- py3-pytest
- py3-pytest-black
- py3-pytest-cov
- py3-pytest-flake8
+ py3-wheel
"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/i/inflect/inflect-$pkgver.tar.gz"
builddir="$srcdir/inflect-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$PWD/build/lib" pytest --ignore setup.py
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="f5baf65fb7a6ba59c91a36a17acb0abda3efc74fef56b3a3d99c100b2c6e94c5aafb08ab37310ce410631ac928e9c24a4a4c5e6b5c7d8f907c3d999f4a70cce4 inflect-5.3.0.tar.gz"
+sha512sums="
+13b698637a8049987675dd419359907baba6d8a9805c3602bbc414ed8fb422bfaa32ec26bcc309508ead5cb72bed632d9142f7796c981269551f1238b88c9019 inflect-7.2.0.tar.gz
+"