aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-inform/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-inform/APKBUILD')
-rw-r--r--community/py3-inform/APKBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/community/py3-inform/APKBUILD b/community/py3-inform/APKBUILD
index 0178ed91140..98e6b5fcc14 100644
--- a/community/py3-inform/APKBUILD
+++ b/community/py3-inform/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Andy Hawkins <andy@gently.org.uk>
# Maintainer: Andy Hawkins <andy@gently.org.uk>
pkgname=py3-inform
-pkgver=1.25
-pkgrel=0
+pkgver=1.28
+pkgrel=2
pkgdesc="Print & Logging Utilities"
url="https://inform.readthedocs.io/"
arch="noarch"
@@ -13,18 +13,22 @@ depends="
py3-six
"
makedepends="
- py3-pytest-runner
- py3-setuptools
+ py3-flit-core
+ py3-gpep517
"
checkdepends="
py3-pytest
+ py3-pytest-cov
py3-hypothesis
"
+subpackages="$pkgname-pyc"
source="https://github.com/KenKundert/inform/archive/v$pkgver/inform-v$pkgver.tar.gz"
builddir="$srcdir/inform-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -32,8 +36,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/inform-$pkgver*-py3-none-any.whl
}
+
sha512sums="
-993544c8e9d77b14279aacf012444ad920a3b4d4858de56f1aecccd2294d8b2af4068cf4d1be20c99e0d54b4c2b414e33b5a0a2912d5fad0ea6a1ac192cd7a4c inform-v1.25.tar.gz
+68840f92e0efa7d5604f4c23623cb7829519962301e659bf18aff22070335e54b699f6eb3ce1f3321dfd9cb15b8941d3ec3901f7069ae862f3c0deeed6372803 inform-v1.28.tar.gz
"