aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-inform/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-inform/APKBUILD')
-rw-r--r--community/py3-inform/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/community/py3-inform/APKBUILD b/community/py3-inform/APKBUILD
index 4bed4915cb1..c9218dd547b 100644
--- a/community/py3-inform/APKBUILD
+++ b/community/py3-inform/APKBUILD
@@ -13,9 +13,8 @@ depends="
py3-six
"
makedepends="
- py3-build
py3-flit-core
- py3-installer
+ py3-gpep517
"
checkdepends="
py3-pytest
@@ -34,7 +33,9 @@ prepare() {
}
build() {
- python3 -m build --no-isolation --wheel .
+ gpep517 build-wheel \
+ --wheel-dir dist \
+ --output-fd 1
}
check() {