aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-iniherit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-iniherit/APKBUILD')
-rw-r--r--community/py3-iniherit/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/community/py3-iniherit/APKBUILD b/community/py3-iniherit/APKBUILD
index 8fe62a7ebec..f0f9266db37 100644
--- a/community/py3-iniherit/APKBUILD
+++ b/community/py3-iniherit/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-iniherit
pkgver=0.3.9
-pkgrel=3
+pkgrel=8
pkgdesc="ConfigParser subclass with file-specified inheritance"
url="https://github.com/cadithealth/iniherit"
arch="noarch"
@@ -11,6 +11,7 @@ depends="py3-six"
makedepends="python3-dev py3-setuptools"
checkdepends="py3-nose py3-coverage"
options="!check" # broken, recurse until they hit the recursion limit
+subpackages="$pkgname-pyc"
source="https://pypi.io/packages/source/i/iniherit/iniherit-$pkgver.tar.gz"
builddir="$srcdir/iniherit-$pkgver"
@@ -23,7 +24,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="097e300c0066e9b035dd28dda87a392102e7f45130471e903e222bdaf209a154f92e08db22f4b6547bdbe25f1e5350e2cec4064b0ed7d86fbed0f0f623946c27 iniherit-0.3.9.tar.gz"