aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-inquirer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-inquirer/APKBUILD')
-rw-r--r--community/py3-inquirer/APKBUILD33
1 files changed, 15 insertions, 18 deletions
diff --git a/community/py3-inquirer/APKBUILD b/community/py3-inquirer/APKBUILD
index 072a7613bda..e814ea74630 100644
--- a/community/py3-inquirer/APKBUILD
+++ b/community/py3-inquirer/APKBUILD
@@ -1,39 +1,36 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-inquirer
-pkgver=2.7.0
-pkgrel=2
+pkgver=3.2.4
+pkgrel=1
pkgdesc="collection of common interactive command line user interfaces"
url="https://github.com/magmax/python-inquirer"
arch="noarch"
license="MIT"
depends="python3 py3-blessed py3-readchar py3-python-editor"
-makedepends="py3-setuptools"
+makedepends="py3-poetry-core py3-gpep517 py3-installer py3-wheel"
checkdepends="py3-flake8 py3-pexpect py3-pytest py3-pytest-cov py3-pytest-xdist
py3-mock py3-nosexcover py3-coveralls py3-wheel ncurses-terminfo"
# GH tarballs required for tests!
-source="$pkgname-$pkgver.tar.gz::https://github.com/magmax/python-inquirer/archive/$pkgver.tar.gz
- loosen-deps.patch
- use-py3-in-tests.patch
- disable-failing-tests.patch
- "
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/magmax/python-inquirer/archive/v$pkgver.tar.gz"
builddir="$srcdir/python-inquirer-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- TERM=xterm-256color python3 setup.py test
+ TERM=xterm-256color PYTHONPATH=src pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
- # Remove installed tests
- rm -r "$pkgdir"/usr/lib/python*/site-packages/tests
+ python3 -m installer -d "$pkgdir" \
+ .dist/inquirer-$pkgver-*.whl
}
-sha512sums="a837334409edb80817b23676def95b60210ea409bb6b761e4f6ec307f36df4b2a07612abd0b46fe69848f4c7c9ea8b94f98972efef512f88a11b2b661e55d6f4 py3-inquirer-2.7.0.tar.gz
-00d471b866d93a34424606395056365e10af5260bb67f4aff989d50389c74426ed01bf053f076fd800dc1c3ca366a913c7fc80a79e570177b4660da02f92f647 loosen-deps.patch
-08cb9047bdbb04f27162eb58c3ad6dbf0905b7a320e02be07c117f351967aa0059b14923cbbd5e73192b5009e58b70555550d010e0a857dbb9c69277488111ba use-py3-in-tests.patch
-cbc376ae4f3200fbaa9b008a8c00ad264808421be2cccea08fb903f3dcf00a773a00ac0b928b71fc1e884b7341e73be38e79d32e4693fe263b635b0d4a6b6a7b disable-failing-tests.patch"
+sha512sums="
+3960ca5bf836bc56431658ede39e86e40cce6cb368f7fced5f364d76ceb1b458c3ac3fb02ee3878d2bf978f5b33bb6867e87520b9d6407210eea5a912a2cb1f3 py3-inquirer-3.2.4.tar.gz
+"