aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ipykernel/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-ipykernel/APKBUILD')
-rw-r--r--community/py3-ipykernel/APKBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/community/py3-ipykernel/APKBUILD b/community/py3-ipykernel/APKBUILD
index 5ca7b83dac6..bcc60457201 100644
--- a/community/py3-ipykernel/APKBUILD
+++ b/community/py3-ipykernel/APKBUILD
@@ -1,41 +1,49 @@
# Contributor: Aiden Grossman <agrossman154@yahoo.com>
# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
pkgname=py3-ipykernel
-pkgver=6.15.0
-pkgrel=0
+pkgver=6.25.2
+pkgrel=1
pkgdesc="IPython kernel for jupyter"
url="https://github.com/ipython/ipykernel"
arch="noarch"
license="BSD-3-Clause"
depends="
ipython
+ py3-comm
py3-jupyter_client
+ py3-jupyter_core
py3-matplotlib-inline
py3-nest_asyncio
py3-packaging
py3-psutil
+ py3-pyzmq
py3-tornado
py3-traitlets
- python3
"
-makedepends="py3-build py3-installer py3-hatchling"
-checkdepends="py3-ipyparallel py3-pytest py3-flaky py3-pytest-timeout"
-source="$pkgname-$pkgver.tar.gz::https://github.com/ipython/ipykernel/releases/download/v$pkgver/ipykernel-$pkgver.tar.gz"
+makedepends="py3-gpep517 py3-hatchling"
+checkdepends="py3-ipyparallel py3-pytest py3-flaky py3-pytest-timeout py3-pytest-asyncio"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ipython/ipykernel/releases/download/v$pkgver/ipykernel-$pkgver.tar.gz
+ deprecation-warnings.patch"
builddir="$srcdir/ipykernel-$pkgver"
options="!check" # py3-ipyparallel is circular, and an optional dep
build() {
- python3 -m build --wheel --no-isolation --skip-dependency-check
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ pytest \
+ --deselect ipykernel/tests/test_kernel.py::test_shutdown_subprocesses
}
package() {
- python3 -m installer --destdir="$pkgdir" dist/*.whl
+ python3 -m installer --destdir="$pkgdir" .dist/*.whl
}
sha512sums="
-a6533f094d18d32a02e8de5638fdabb9f647edc9a512e609de3bb1d80f5592acef4e930d879bf79bde7a0ca23945d9eb112d841f2305204fac9f4c672b5315ac py3-ipykernel-6.15.0.tar.gz
+a6f5089cff8c297379ae840b49ad705d23db46aa04030c7a2598031d118b5c0dd64e091de4d66adfd876e8ef45abfcb6bc963c3311dd8e50f4e83236bfc4cfa3 py3-ipykernel-6.25.2.tar.gz
+5e1ccda828995dabc4e156dcb8e3f53bd99dcdfff6d109e9278d7daecd63db7b7973d5652ff68c180d7147d54cb42b66841e5bca0560078d38b698d93995be4e deprecation-warnings.patch
"