aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ipyparallel/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-ipyparallel/APKBUILD')
-rw-r--r--community/py3-ipyparallel/APKBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/community/py3-ipyparallel/APKBUILD b/community/py3-ipyparallel/APKBUILD
index e8d969bda56..2a0d46d9e0e 100644
--- a/community/py3-ipyparallel/APKBUILD
+++ b/community/py3-ipyparallel/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Aiden Grossman <agrossman154@yahoo.com>
# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
pkgname=py3-ipyparallel
-pkgver=8.4.0
-pkgrel=0
+pkgver=8.7.0
+pkgrel=1
pkgdesc="Interactive parallel python computing"
url="https://github.com/ipython/ipyparallel"
arch="noarch"
@@ -21,25 +21,31 @@ depends="
py3-matplotlib-inline
py3-ipykernel
"
-makedepends="py3-build py3-flit-core py3-installer py3-hatchling"
+makedepends="py3-gpep517 py3-installer py3-hatchling"
checkdepends="py3-pytest py3-pytest-asyncio"
options="!check" # has a circular dependency with py3-ipykernel
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ipython/ipyparallel/archive/refs/tags/$pkgver.tar.gz"
builddir="$srcdir/ipyparallel-$pkgver"
build() {
- IPP_DISABLE_JS=1 python3 -m build --wheel --no-isolation --skip-dependency-check
+ IPP_DISABLE_JS=1 \
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m installer --destdir=test_install dist/*.whl
- PYTHONPATH="$PWD/test_install" pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 -m installer --destdir="$pkgdir" dist/*.whl
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-4ea4ebdfe7295df2bf53d95c41346e478ccbb15872b05bb964ebfd059d43d5b9a34fc9679d8ffd4b5d0a5ea737e2d4845dfba3c231d60075a1483b662d1bad2a py3-ipyparallel-8.4.0.tar.gz
+57db92c45e9f481ef6364a95fdef2caaea20bc427a886c8bf0edce5a5ce1001e6e4b754136c3b8b6ecbd1c05a4239cd6000f881061dd7136b33b9293d48c15d6 py3-ipyparallel-8.7.0.tar.gz
"