aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ipython_genutils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-ipython_genutils/APKBUILD')
-rw-r--r--community/py3-ipython_genutils/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/community/py3-ipython_genutils/APKBUILD b/community/py3-ipython_genutils/APKBUILD
index cf339194077..efdcb38f33e 100644
--- a/community/py3-ipython_genutils/APKBUILD
+++ b/community/py3-ipython_genutils/APKBUILD
@@ -2,17 +2,21 @@
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=py3-ipython_genutils
pkgver=0.2.0
-pkgrel=5
+pkgrel=9
pkgdesc="Vestigial IPython utilities"
url="https://github.com/ipython/ipython_genutils"
arch="noarch"
license="BSD-3-Clause"
depends="python3"
+makedepends="py3-setuptools"
checkdepends="py3-nose"
-source="$pkgname-$pkgver.tar.gz::https://github.com/ipython/ipython_genutils/archive/$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ipython/ipython_genutils/archive/$pkgver.tar.gz
+ assertEquals.patch
+ "
builddir="$srcdir/${pkgname#py3-}-$pkgver"
replaces="py-ipython_genutils"
-provides="py-ipython_genutils"
+provides="py-ipython_genutils=$pkgver-r$pkgrel"
build() {
python3 setup.py build
@@ -23,9 +27,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="
b238fce8ba437328b9cd78871cd8a8ab562c513d33db95be74296233114a39eb8a3b3c64fbfb149bc3d42d3eb7762defc03befb9862d6aefbaad389d2838f854 py3-ipython_genutils-0.2.0.tar.gz
+534b5af87980cea508c0ab6b8696428012d0bfa5e09430c903768e4d0e93220fe79ce66579d0ddb8e0a02f1b207967f1f13d40e31dd09f62cf410388c247d983 assertEquals.patch
"