aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ipython_genutils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-ipython_genutils/APKBUILD')
-rw-r--r--community/py3-ipython_genutils/APKBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/community/py3-ipython_genutils/APKBUILD b/community/py3-ipython_genutils/APKBUILD
index a9ecd0e7e6f..e3cee5e01ec 100644
--- a/community/py3-ipython_genutils/APKBUILD
+++ b/community/py3-ipython_genutils/APKBUILD
@@ -2,24 +2,31 @@
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=py3-ipython_genutils
pkgver=0.2.0
-pkgrel=1
+pkgrel=8
pkgdesc="Vestigial IPython utilities"
url="https://github.com/ipython/ipython_genutils"
arch="noarch"
license="BSD-3-Clause"
-makedepends="python3-dev"
-options="!check" # No test suite
+depends="python3"
+checkdepends="py3-nose"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ipython/ipython_genutils/archive/$pkgver.tar.gz"
builddir="$srcdir/${pkgname#py3-}-$pkgver"
replaces="py-ipython_genutils"
-provides="py-ipython_genutils"
+provides="py-ipython_genutils=$pkgver-r$pkgrel"
build() {
python3 setup.py build
}
+check() {
+ nosetests ipython_genutils
+}
+
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="b238fce8ba437328b9cd78871cd8a8ab562c513d33db95be74296233114a39eb8a3b3c64fbfb149bc3d42d3eb7762defc03befb9862d6aefbaad389d2838f854 py3-ipython_genutils-0.2.0.tar.gz"
+sha512sums="
+b238fce8ba437328b9cd78871cd8a8ab562c513d33db95be74296233114a39eb8a3b3c64fbfb149bc3d42d3eb7762defc03befb9862d6aefbaad389d2838f854 py3-ipython_genutils-0.2.0.tar.gz
+"