aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-isort/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-isort/APKBUILD')
-rw-r--r--community/py3-isort/APKBUILD36
1 files changed, 24 insertions, 12 deletions
diff --git a/community/py3-isort/APKBUILD b/community/py3-isort/APKBUILD
index 95243f58c72..9532f546212 100644
--- a/community/py3-isort/APKBUILD
+++ b/community/py3-isort/APKBUILD
@@ -1,40 +1,52 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-isort
-pkgver=5.10.1
-pkgrel=0
+pkgver=5.13.2
+pkgrel=1
pkgdesc="Python library to sort Python imports"
-url="https://github.com/timothycrosley/isort"
+url="https://github.com/PyCQA/isort"
arch="noarch"
license="MIT"
depends="python3"
makedepends="
- py3-setuptools
+ py3-gpep517
+ py3-poetry-core
"
checkdepends="
black
+ py3-hypothesis
py3-pytest
+ py3-colorama
"
-source="https://pypi.python.org/packages/source/i/isort/isort-$pkgver.tar.gz"
-# several tests are failing. Needs upstream fix.
-options="!check"
-
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/PyCQA/isort/archive/refs/tags/$pkgver.tar.gz"
builddir="$srcdir/isort-$pkgver"
+options="!check" # tests git clone random stuff
replaces="py-isort" # Backwards compatibility
provides="py-isort=$pkgver-r$pkgrel" # Backwards compatibility
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer \
+ .dist/*.whl
# Ignored tests have unmet dependencies
- pytest \
+ .testenv/bin/python3 -m pytest \
--ignore tests/unit/test_pylama_isort.py \
- --ignore tests/integration
+ --ignore tests/integration/test_hypothesmith.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-ac02a1ae0138a6d85c06335a286c16def68cfe17915a94b3838a7b9f216f435d16244f3519d04f51ec77f9d68d649d6126c0a6316b7b868ff1f1390bc61ca0d2 isort-5.10.1.tar.gz
+fe2bd27f0aa6219d44c3124782d400338a801a911d6a09ad51e7f80cbcbce250838350ad6cc80a35f641e0a319778ddcfb4dc61c8c76999ebc63a5147953e378 py3-isort-5.13.2.tar.gz
"