aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-itypes/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-itypes/APKBUILD')
-rw-r--r--community/py3-itypes/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/community/py3-itypes/APKBUILD b/community/py3-itypes/APKBUILD
index 7884cf16244..cacbbc8d2b9 100644
--- a/community/py3-itypes/APKBUILD
+++ b/community/py3-itypes/APKBUILD
@@ -3,14 +3,15 @@
pkgname=py3-itypes
_pkgreal=itypes
pkgver=1.2.0
-pkgrel=2
+pkgrel=6
pkgdesc="Basic immutable container types for Python"
-url="https://github.com/tomchristie/itypes"
+url="https://github.com/PavanTatikonda/itypes"
arch="noarch"
license="BSD-3-Clause"
makedepends="py3-setuptools"
checkdepends="py3-flake8 py3-pytest py3-pyflakes"
-source="$pkgname-$pkgver.tar.gz::https://github.com/tomchristie/itypes/archive/$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/PavanTatikonda/itypes/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgreal-$pkgver
replaces="py-itypes" # Backwards compatibility
@@ -25,7 +26,7 @@ check() {
}
package() {
- python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
+ python3 setup.py --quiet install --skip-build --root="$pkgdir"
}
sha512sums="94421fa3f9ec7d18989332ca518607f09bd9d674e80bbca4a3c7324c20c3ae4e0679457e6a328e50ffe3d94c6db733f092798293133d42c1f07d959e0f837891 py3-itypes-1.2.0.tar.gz"