aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-itypes/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-itypes/APKBUILD')
-rw-r--r--community/py3-itypes/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/community/py3-itypes/APKBUILD b/community/py3-itypes/APKBUILD
index 3b450416e77..cacbbc8d2b9 100644
--- a/community/py3-itypes/APKBUILD
+++ b/community/py3-itypes/APKBUILD
@@ -2,15 +2,16 @@
# Maintainer:
pkgname=py3-itypes
_pkgreal=itypes
-pkgver=1.1.0
-pkgrel=4
+pkgver=1.2.0
+pkgrel=6
pkgdesc="Basic immutable container types for Python"
-url="https://github.com/tomchristie/itypes"
+url="https://github.com/PavanTatikonda/itypes"
arch="noarch"
license="BSD-3-Clause"
makedepends="py3-setuptools"
checkdepends="py3-flake8 py3-pytest py3-pyflakes"
-source="$pkgname-$pkgver.tar.gz::https://github.com/tomchristie/itypes/archive/$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/PavanTatikonda/itypes/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgreal-$pkgver
replaces="py-itypes" # Backwards compatibility
@@ -25,7 +26,7 @@ check() {
}
package() {
- python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
+ python3 setup.py --quiet install --skip-build --root="$pkgdir"
}
-sha512sums="2f6dd5d655f1031059df8dcfd0a2f76875796a800144e887fb66cb5585949097edb6b9f5e973de2280f43cfeb25ab99d3ca428372fe239c8cd70f385304bcdd7 py3-itypes-1.1.0.tar.gz"
+sha512sums="94421fa3f9ec7d18989332ca518607f09bd9d674e80bbca4a3c7324c20c3ae4e0679457e6a328e50ffe3d94c6db733f092798293133d42c1f07d959e0f837891 py3-itypes-1.2.0.tar.gz"