aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-jaraco.collections/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-jaraco.collections/APKBUILD')
-rw-r--r--community/py3-jaraco.collections/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/community/py3-jaraco.collections/APKBUILD b/community/py3-jaraco.collections/APKBUILD
index 61af36feba4..8de3993c258 100644
--- a/community/py3-jaraco.collections/APKBUILD
+++ b/community/py3-jaraco.collections/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-jaraco.collections
-pkgver=3.5.1
+pkgver=5.0.1
pkgrel=0
pkgdesc="jaraco - Module for text manipulation"
url="https://github.com/jaraco/jaraco.collections"
@@ -10,13 +10,16 @@ arch="noarch"
license="MIT"
depends="py3-jaraco.classes py3-jaraco.text"
# py3-setuptools_scm is needed to set python module version
-makedepends="py3-setuptools py3-setuptools_scm"
+makedepends="py3-gpep517 py3-setuptools py3-setuptools_scm py3-wheel"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/j/jaraco.collections/jaraco.collections-$pkgver.tar.gz"
builddir="$srcdir/jaraco.collections-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -24,9 +27,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/jaraco.collections-$pkgver-py3-none-any.whl
}
sha512sums="
-2918be537296ca81e5f78a3966a47451dc9dc2d233d997c3f01461c489b44051c497dab55496f85883ac1b91a28850a9d77ff154a3f5e074da1ed07f3259c246 jaraco.collections-3.5.1.tar.gz
+88b0f261acd91d585e643b810818762af7165eaf505099701b99ee3be6955eebcfd1c95690faa3ecb56b25f6982a8cee242e687e50ead56a557a5b2b72ec6dfe jaraco.collections-5.0.1.tar.gz
"