aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-jaraco.context/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-jaraco.context/APKBUILD')
-rw-r--r--community/py3-jaraco.context/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/community/py3-jaraco.context/APKBUILD b/community/py3-jaraco.context/APKBUILD
new file mode 100644
index 00000000000..838d5c60bb1
--- /dev/null
+++ b/community/py3-jaraco.context/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-jaraco.context
+pkgver=5.3.0
+pkgrel=0
+pkgdesc="Context managers by jaraco"
+url="https://github.com/jaraco/jaraco.context"
+arch="noarch"
+license="MIT"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-setuptools_scm
+ py3-wheel
+ "
+checkdepends="
+ py3-portend
+ py3-pytest
+ "
+subpackages="$pkgname-pyc"
+source="https://pypi.python.org/packages/source/j/jaraco.context/jaraco.context-$pkgver.tar.gz"
+builddir="$srcdir/jaraco.context-$pkgver"
+
+# backwards compatibility for old name
+replaces="py3-jaraco-context"
+provides="py3-jaraco-context=$pkgver-r$pkgrel"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
+
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" .dist/jaraco.context-$pkgver-py3-none-any.whl
+}
+
+sha512sums="
+f63bf272c45ff5c43499621651b78841259040ac98d67c9db75fadebb1c497c1156e05f23bf7c91df3e91f1e070acb9f7dc665e7b242ba7b1ac1cf99a619494d jaraco.context-5.3.0.tar.gz
+"