aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-jaraco.envs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-jaraco.envs/APKBUILD')
-rw-r--r--community/py3-jaraco.envs/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/community/py3-jaraco.envs/APKBUILD b/community/py3-jaraco.envs/APKBUILD
new file mode 100644
index 00000000000..2826b7df492
--- /dev/null
+++ b/community/py3-jaraco.envs/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-jaraco.envs
+pkgver=2.6.0
+pkgrel=0
+pkgdesc="Classes for orchestrating Python (virtual) environments"
+url="https://github.com/jaraco/jaraco.envs"
+arch="noarch"
+license="MIT"
+depends="py3-path"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-setuptools_scm
+ py3-wheel
+ "
+checkdepends="
+ py3-pytest
+ py3-tox
+ py3-virtualenv
+ "
+subpackages="$pkgname-pyc"
+source="https://pypi.python.org/packages/source/j/jaraco.envs/jaraco.envs-$pkgver.tar.gz"
+builddir="$srcdir/jaraco.envs-$pkgver"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" .dist/*.whl
+}
+
+sha512sums="
+8c1d4717f45b805ae3afa1308a60c0f6f03af2a0976f2fb52329d05114282c2f33085865c93e34065bfd978e52ed8bd65f9903ed8e3c7d8b23bf6a050a32bd08 jaraco.envs-2.6.0.tar.gz
+"