aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-jaraco.functools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-jaraco.functools/APKBUILD')
-rw-r--r--community/py3-jaraco.functools/APKBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/community/py3-jaraco.functools/APKBUILD b/community/py3-jaraco.functools/APKBUILD
index fd029d595ab..0ac203342df 100644
--- a/community/py3-jaraco.functools/APKBUILD
+++ b/community/py3-jaraco.functools/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-jaraco.functools
-pkgver=3.5.0
+pkgver=4.0.1
pkgrel=0
pkgdesc="Functools like those found in stdlib"
url="https://github.com/jaraco/jaraco.functools"
@@ -10,32 +10,41 @@ license="MIT"
# py3-setuptools_scm is required to set version of python module
depends="
py3-jaraco.classes
+ py3-more-itertools
python3
"
makedepends="
+ py3-gpep517
py3-setuptools
py3-setuptools_scm
+ py3-wheel
"
checkdepends="py3-pytest"
-source="https://pypi.python.org/packages/source/j/jaraco.functools/jaraco.functools-$pkgver.tar.gz"
-builddir="$srcdir/jaraco.functools-$pkgver"
+subpackages="$pkgname-pyc"
+source="https://pypi.python.org/packages/source/j/jaraco_functools/jaraco_functools-$pkgver.tar.gz"
+builddir="$srcdir/jaraco_functools-$pkgver"
# backwards compatibility for old name
replaces="py3-jaraco-functools"
provides="py3-jaraco-functools=$pkgver-r$pkgrel"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-7257f41506f90ca2fda1bd12fed58fa4d4ff5738547f8cdae8ccad1901e0c818afb701dd8e9050fc77ca1271bc2466d5a542990138bc3db2cf9b04d12850844c jaraco.functools-3.5.0.tar.gz
+04e0ea4719ec8c4439e5a1dd3c3ba0241b21b54b06d53ecc44263046e994aa736b9d196490edd3fd9d7ea997c23c177b30db506b2088bd9de62c637856101982 jaraco_functools-4.0.1.tar.gz
"