aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-jeepney/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-jeepney/APKBUILD')
-rw-r--r--community/py3-jeepney/APKBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/community/py3-jeepney/APKBUILD b/community/py3-jeepney/APKBUILD
index 348dfe0164f..226ef4971b6 100644
--- a/community/py3-jeepney/APKBUILD
+++ b/community/py3-jeepney/APKBUILD
@@ -1,23 +1,32 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=py3-jeepney
-pkgver=0.6.0
-pkgrel=0
+pkgver=0.8.0
+pkgrel=4
pkgdesc="Low-level, pure Python DBus protocol wrapper"
options="!check" # Requires unpackaged testpath
url="https://gitlab.com/takluyver/jeepney"
arch="noarch"
license="MIT"
depends="python3"
+makedepends="py3-flit-core py3-gpep517"
+subpackages="$pkgname-pyc"
source="https://pypi.io/packages/source/j/jeepney/jeepney-$pkgver.tar.gz"
builddir="$srcdir"/jeepney-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/jeepney-$pkgver-py3-none-any.whl
+ rm -rf "$pkgdir"/usr/lib/python3*/site-packages/jeepney/tests
+ rm -rf "$pkgdir"/usr/lib/python3*/site-packages/jeepney/*/tests
}
-sha512sums="140be9dd28ed853d2d41b6a8bbeb2f22c0270ce7bf33b943ec2ac010db17d4f06e253fa8637fbbb3044fe9ffdbfa1e15f0c663eb44bdd538f8c47c2e7dab3ca5 jeepney-0.6.0.tar.gz"
+sha512sums="
+823675f262c2c9778ccf9c1083601d936cca534fc0d2d9309b52aa6beeb7f73d225a37c5f18f6b0683c4829a93b1299a2cb4f8f341e55b92bedf58c8dce0aa75 jeepney-0.8.0.tar.gz
+"