aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-jellyfish/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-jellyfish/APKBUILD')
-rw-r--r--community/py3-jellyfish/APKBUILD28
1 files changed, 20 insertions, 8 deletions
diff --git a/community/py3-jellyfish/APKBUILD b/community/py3-jellyfish/APKBUILD
index 1f29ea2c2c8..6af4382f6c7 100644
--- a/community/py3-jellyfish/APKBUILD
+++ b/community/py3-jellyfish/APKBUILD
@@ -1,24 +1,36 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=py3-jellyfish
-pkgver=0.8.2
-pkgrel=2
+pkgver=1.0.3
+pkgrel=1
pkgdesc="Python library for approximate and phonetic string matching"
url="https://github.com/jamesturk/jellyfish"
arch="all"
license="BSD-2-Clause"
-replaces="py-jellyfish" # for backwards compatibility
-provides="py-jellyfish=$pkgver-r$pkgrel" # for backwards compatibility
-makedepends="python3-dev py3-setuptools"
+replaces="py-jellyfish" # for backwards compatibility
+provides="py-jellyfish=$pkgver-r$pkgrel" # for backwards compatibility
+makedepends="
+ cargo
+ py3-gpep517
+ py3-maturin
+ python3-dev
+ "
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/j/jellyfish/jellyfish-$pkgver.tar.gz"
builddir="$srcdir/jellyfish-$pkgver"
+options="net"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="c4cc2b22df37497ed1ee595f03ec10b7ffe6b8441accaea77ca1b6018df07d23bbe9f2ed72d0c3e06792d6e1229b7e56f77f1758396d83120236d018ce2328da jellyfish-0.8.2.tar.gz"
+sha512sums="
+dc977cff57c3aaad3564dabcae1155e05389bd16c37f0b836f81fea26df42dc0b4397ed17ee3f130d53c967007c3c7a322a917dfdc7a87cf2c340ce33552b09a jellyfish-1.0.3.tar.gz
+"