aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-jsonpatch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-jsonpatch/APKBUILD')
-rw-r--r--community/py3-jsonpatch/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/community/py3-jsonpatch/APKBUILD b/community/py3-jsonpatch/APKBUILD
index b863de97e3b..e30d594b8ee 100644
--- a/community/py3-jsonpatch/APKBUILD
+++ b/community/py3-jsonpatch/APKBUILD
@@ -1,16 +1,18 @@
# Contributor: Matt Dainty <matt+alpine@bodgit-n-scarper.com>
# Contributor: TBK <alpine@jjtc.eu>
-# Maintainer: Dermot Bradley <dermot_bradley@yahoo.com>
+# Contributor: Dermot Bradley <dermot_bradley@yahoo.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=py3-jsonpatch
_pkgname=python-json-patch
-pkgver=1.32
-pkgrel=1
+pkgver=1.33
+pkgrel=2
pkgdesc="Apply JSON-Patches (RFC 6902)"
url="https://github.com/stefankoegl/python-json-patch"
arch="noarch"
license="BSD-3-Clause"
depends="py3-jsonpointer"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/stefankoegl/python-json-patch/archive/v$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -26,7 +28,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="4e2978555dd506e09553014d426c4e3a6c6d5c865428f11450952704007c8a0b2060b945cf1fa33a128151427e1c66919891466e095e96fff4316304f0b3ad1d py3-jsonpatch-1.32.tar.gz"
+sha512sums="0685f63949bee135b19d0962bdaab32ba97e02772b6650d885be57c09a2e89546222ebba1a4cf146b2f91027790b0a3ff2ea072d66dcebf9153aa601638bbfa2 py3-jsonpatch-1.33.tar.gz"