aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-jsonschema/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-jsonschema/APKBUILD')
-rw-r--r--community/py3-jsonschema/APKBUILD53
1 files changed, 35 insertions, 18 deletions
diff --git a/community/py3-jsonschema/APKBUILD b/community/py3-jsonschema/APKBUILD
index cbfc5640c5d..0aa99c2a3e0 100644
--- a/community/py3-jsonschema/APKBUILD
+++ b/community/py3-jsonschema/APKBUILD
@@ -1,42 +1,59 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-jsonschema
-pkgver=4.5.1
-pkgrel=0
-pkgdesc="An implementation of JSON Schema validation for Python"
-url="https://github.com/Julian/jsonschema"
+pkgver=4.21.1
+pkgrel=1
+pkgdesc="JSON Schema validation for Python"
+url="https://github.com/python-jsonschema/jsonschema"
arch="noarch"
license="MIT"
-depends="python3 py3-pyrsistent py3-attrs py3-six"
-makedepends="py3-build py3-installer py3-setuptools_scm py3-wheel"
-checkdepends="py3-twisted py3-pytest py3-tox"
-source="https://files.pythonhosted.org/packages/source/j/jsonschema/jsonschema-$pkgver.tar.gz"
+depends="
+ py3-attrs
+ py3-jsonschema-specifications
+ py3-referencing
+ py3-rpds-py
+ "
+makedepends="
+ py3-gpep517
+ py3-hatch-fancy-pypi-readme
+ py3-hatch-vcs
+ py3-hatchling
+ py3-installer
+ py3-wheel
+ "
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/j/jsonschema/jsonschema-$pkgver.tar.gz
+ skip-license-test.patch
+ "
builddir="$srcdir/jsonschema-$pkgver"
+options="!check" # the tests take forever
replaces="py-jsonschema" # Backwards compatibility
provides="py-jsonschema=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 -m build --no-isolation --wheel
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$PWD/build/lib" py.test-3 -v \
- --deselect jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
python3 -m installer -d "$pkgdir" \
- dist/jsonschema-$pkgver-py3-none-any.whl
+ .dist/jsonschema-$pkgver-py3-none-any.whl
- # Add version suffix to executable files.
- local path; for path in "$pkgdir"/usr/bin/*; do
- mv "$path" "$path"-3
- done
+ rm -r "$pkgdir"/usr/lib/python*/site-packages/jsonschema/tests
- ln -s jsonschema-3 "$pkgdir"/usr/bin/jsonschema
+ ln -s jsonschema "$pkgdir"/usr/bin/jsonschema-3
}
sha512sums="
-3866a649ece45c1c69d3d5e9810cfdb094f1af82fcc08a186f9babd7516ad311c4bffa52f61f013bc84e7ab1be06605c5fab738c1c920ff8ce85a73429d9efde jsonschema-4.5.1.tar.gz
+b0744a80d64572307860c9238ff5048e062b7665d9ed97dd390bae0b168ab96497f359ddc4e95f052d8b177161e5b808ee432bd9fe182c1ea39cbad417db9278 jsonschema-4.21.1.tar.gz
+4e74925bfa689bb53840f31faed361463e82bb2fd16c86a90de7cbcd0d1d6949c81944bc60e8d2068a6043e1da64b62fd48a062d683e9b96d6bc9b6603b2ccd6 skip-license-test.patch
"