aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-jupyter_client/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-jupyter_client/APKBUILD')
-rw-r--r--community/py3-jupyter_client/APKBUILD43
1 files changed, 31 insertions, 12 deletions
diff --git a/community/py3-jupyter_client/APKBUILD b/community/py3-jupyter_client/APKBUILD
index b78421aa235..39dd69f3150 100644
--- a/community/py3-jupyter_client/APKBUILD
+++ b/community/py3-jupyter_client/APKBUILD
@@ -1,40 +1,59 @@
# Contributor: Aiden Grossman <agrossman154@yahoo.com>
# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
pkgname=py3-jupyter_client
-pkgver=7.3.1
+pkgver=8.6.1
pkgrel=0
pkgdesc="Jupyter protocol client APIs"
url="https://github.com/jupyter/jupyter_client"
arch="noarch"
license="BSD-3-Clause"
depends="
- py3-traitlets
- py3-pyzmq
+ py3-dateutil
py3-jupyter_core
- py3-entrypoints
+ py3-pyzmq
py3-tornado
- py3-nest_asyncio
- py3-dateutil
+ py3-traitlets
+ "
+makedepends="py3-gpep517 py3-hatchling"
+checkdepends="
+ ipython
+ openssh
+ py3-ipykernel
+ py3-pytest
+ py3-pytest-asyncio
+ py3-pytest-jupyter
+ py3-pytest-timeout
"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest ipython py3-ipykernel"
# circular dependency with py3-ipykernel
options="!check"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/jupyter/jupyter_client/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir/jupyter_client-$pkgver/"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ # first test fails on empty queue, more investigation needed
+ # last test has a file descriptor related error, more investigation needed
+ # other tests all hit their specified timeout
+ pytest -vv \
+ --deselect tests/test_kernelmanager.py::TestKernelManager::test_signal_kernel_subprocesses \
+ --deselect tests/test_kernelmanager.py::TestParallel::test_start_parallel_thread_kernels \
+ --deselect tests/test_kernelmanager.py::TestParallel::test_start_sequence_kernels \
+ --deselect tests/test_kernelmanager.py::TestParallel::test_start_parallel_process_kernels \
+ --deselect tests/test_kernelmanager.py::TestParallel::test_start_sequence_process_kernels \
+ --deselect tests/test_kernelmanager.py::TestAsyncKernelManager::test_signal_kernel_subprocesses \
+ --deselect tests/test_multikernelmanager.py::TestKernelManager::test_tcp_cinfo
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer --destdir="$pkgdir" .dist/*.whl
}
sha512sums="
-0120b2159d05363b177205e3a1625ce55fdb83df5e29911d913b8cc45767d536d3385609dfdecb390c0437885869b9d71ea7b7f7554cc34eac656c4466e12744 py3-jupyter_client-7.3.1.tar.gz
+441ecaa3e2d8a44361458c2bfcde328db631890b424dd98391c329477077739985ac948892539a1491c00fe76021e576978b373f1d56adc2a45ae91aff76acb3 py3-jupyter_client-8.6.1.tar.gz
"