aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-jupyter_core/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-jupyter_core/APKBUILD')
-rw-r--r--community/py3-jupyter_core/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/community/py3-jupyter_core/APKBUILD b/community/py3-jupyter_core/APKBUILD
index 27624f0f775..0c799202dfc 100644
--- a/community/py3-jupyter_core/APKBUILD
+++ b/community/py3-jupyter_core/APKBUILD
@@ -1,20 +1,23 @@
# Contributor: Aiden Grossman <agrossman154@yahoo.com>
# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
pkgname=py3-jupyter_core
-pkgver=4.10.0
+pkgver=5.3.1
pkgrel=0
pkgdesc="Core Jupyter functionality"
url="https://github.com/jupyter/jupyter_core"
arch="noarch"
license="BSD-3-Clause"
-depends="py3-traitlets"
-makedepends="py3-setuptools"
+depends="py3-traitlets py3-platformdirs"
+makedepends="py3-hatchling py3-gpep517"
checkdepends="py3-pytest"
-source="$pkgname-$pkgver.tar.gz::https://github.com/jupyter/jupyter_core/archive/refs/tags/$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jupyter/jupyter_core/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir/jupyter_core-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -25,13 +28,13 @@ check() {
--deselect jupyter_core/tests/test_paths.py::test_jupyter_path_user_site \
--deselect jupyter_core/tests/test_paths.py::test_jupyter_path_no_user_site \
--deselect jupyter_core/tests/test_command.py::test_argv0
- cd ./docs
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/jupyter_core-$pkgver-py3-none-any.whl
}
sha512sums="
-0d034a2175fb8b5b5f4ec0be671ecb0b112391c8c66144d9af4adb0166a2fd65bf0ae1d1bd57787b1eaccdc2b8d368540e7c0d6862808cdeaebfd9f8fcb1a496 py3-jupyter_core-4.10.0.tar.gz
+6125eb65f28e29797a026fb5fead72b5c33e11c74e15b07d39484658583f2bf69484d610de130b5ce4d3f0987c73300794fe6d67f5f2b0da044c88010a13646c py3-jupyter_core-5.3.1.tar.gz
"