aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-jupyter_core/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-jupyter_core/APKBUILD')
-rw-r--r--community/py3-jupyter_core/APKBUILD34
1 files changed, 19 insertions, 15 deletions
diff --git a/community/py3-jupyter_core/APKBUILD b/community/py3-jupyter_core/APKBUILD
index 27624f0f775..2c34dbe38ad 100644
--- a/community/py3-jupyter_core/APKBUILD
+++ b/community/py3-jupyter_core/APKBUILD
@@ -1,37 +1,41 @@
# Contributor: Aiden Grossman <agrossman154@yahoo.com>
# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
pkgname=py3-jupyter_core
-pkgver=4.10.0
+pkgver=5.7.2
pkgrel=0
pkgdesc="Core Jupyter functionality"
url="https://github.com/jupyter/jupyter_core"
arch="noarch"
license="BSD-3-Clause"
-depends="py3-traitlets"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest"
-source="$pkgname-$pkgver.tar.gz::https://github.com/jupyter/jupyter_core/archive/refs/tags/$pkgver.tar.gz"
+depends="py3-traitlets py3-platformdirs"
+makedepends="py3-hatchling py3-gpep517"
+checkdepends="py3-pytest7"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jupyter/jupyter_core/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir/jupyter_core-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
pytest \
- --deselect jupyter_core/tests/test_command.py::test_not_on_path \
- --deselect jupyter_core/tests/test_command.py::test_path_priority \
- --deselect jupyter_core/tests/test_paths.py::test_jupyter_path_prefer_env \
- --deselect jupyter_core/tests/test_paths.py::test_jupyter_path_user_site \
- --deselect jupyter_core/tests/test_paths.py::test_jupyter_path_no_user_site \
- --deselect jupyter_core/tests/test_command.py::test_argv0
- cd ./docs
+ --deselect tests/test_command.py::test_not_on_path \
+ --deselect tests/test_command.py::test_path_priority \
+ --deselect tests/test_paths.py::test_jupyter_path_prefer_env \
+ --deselect tests/test_paths.py::test_jupyter_path_user_site \
+ --deselect tests/test_paths.py::test_jupyter_path_no_user_site \
+ --deselect tests/test_command.py::test_argv0 \
+ --deselect tests/test_troubleshoot.py::test_troubleshoot
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/jupyter_core-$pkgver-py3-none-any.whl
}
sha512sums="
-0d034a2175fb8b5b5f4ec0be671ecb0b112391c8c66144d9af4adb0166a2fd65bf0ae1d1bd57787b1eaccdc2b8d368540e7c0d6862808cdeaebfd9f8fcb1a496 py3-jupyter_core-4.10.0.tar.gz
+488bb54c633a6a025a4b5046d9f529e868f69f3823fdbaf3c0d711f1f41441956d023bb6e1657f01a61dd43aca513a3d5987add753c84b64a14bfaf3fb73441d py3-jupyter_core-5.7.2.tar.gz
"