aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-jwt
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-jwt')
-rw-r--r--community/py3-jwt/APKBUILD44
-rw-r--r--community/py3-jwt/no-cov-report.patch12
2 files changed, 56 insertions, 0 deletions
diff --git a/community/py3-jwt/APKBUILD b/community/py3-jwt/APKBUILD
new file mode 100644
index 00000000000..98f1c742475
--- /dev/null
+++ b/community/py3-jwt/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Eivind Uggedal <eu@eju.no>
+# Maintainer:
+pkgname=py3-jwt
+_pkgname=PyJWT
+pkgver=1.7.1
+pkgrel=3
+pkgdesc="Python3 JSON Web Token implementation"
+url="https://github.com/jpadilla/pyjwt"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+subpackages="$pkgname-cli"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ no-cov-report.patch
+ "
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces="py-jwt" # Backwards compatibility
+provides="py-jwt=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 -m pytest .
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+cli() {
+ pkgdesc="$pkgdesc (CLI utility)"
+ depends="py3-jwt=$pkgver-r$pkgrel"
+
+ mkdir -p "$subpkgdir"/usr/
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+sha512sums="70cd38127b6848933992c8b88303725ef71bfb430ad42eb63247e549b0bdab2a194137349d43ab02a1c97212dbc89f447ee3f0c5403dd14632b8b4b6b9235fc4 PyJWT-1.7.1.tar.gz
+886877c4e40005d254abf6f00389e7e69e1a781119c29da7632e3f475b526e15b2387ab1bc5bade07234932c3a7396c06298540bdd1596a79a4a5e62b64517fc no-cov-report.patch"
diff --git a/community/py3-jwt/no-cov-report.patch b/community/py3-jwt/no-cov-report.patch
new file mode 100644
index 00000000000..9efb3d22198
--- /dev/null
+++ b/community/py3-jwt/no-cov-report.patch
@@ -0,0 +1,12 @@
+Avoid installing additional test dependencies.
+
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -8,7 +8,6 @@
+ universal = 1
+
+ [tool:pytest]
+-addopts = --cov-report term-missing --cov-config=.coveragerc --cov .
+
+ [aliases]
+ test = pytest